Guides
DocumentationLog In

Installing Coinbase Wallet SDK

This page explains how to install and upgrade Coinbase Wallet SDK.

🚧

The installation package for Coinbase Wallet SDK (formerly WalletLink) is now named @coinbase/wallet-sdk.

Installing Wallet SDK

Install Coinbase Wallet SDK with yarn or npm.

Yarn

  1. Check available versions of Coinbase Wallet SDK:
yarn info @coinbase/wallet-sdk versions
  1. Install a specific version or the latest version:
  • Install specific version:

    yarn add @coinbase/[email protected]
    
  • Install latest version:

    yarn add @coinbase/wallet-sdk
    
  1. Check your installed version:
yarn list @coinbase/wallet-sdk

Npm

  1. Check available versions of Coinbase Wallet SDK:
npm view @coinbase/wallet-sdk versions
  1. Install a specific version or the latest version:
  • Install specific version:

    npm install @coinbase/[email protected]
    
  • Install latest version:

    npm install @coinbase/wallet-sdk
    
  1. Check your installed version:
npm list @coinbase/wallet-sdk

Upgrading Wallet SDK

Upgrade Coinbase Wallet SDK with yarn or npm.

Yarn

  1. Compare your installed version of Coinbase Wallet SDK with the latest available version:
yarn outdated @coinbase/wallet-sdk
  1. Update Coinbase Wallet SDK to the latest:
yarn upgrade @coinbase/wallet-sdk --latest
  1. Check your version:
yarn list @coinbase/wallet-sdk

Npm

  1. Compare your installed version of Coinbase Wallet SDK with the latest available version:
npm outdated @coinbase/wallet-sdk
  1. If necessary, update package.json with the latest version (or major version), for example:
{
  "dependencies": {
    "@coinbase/wallet-sdk": "^3.0.0"
  }
}
  1. Update Coinbase Wallet SDK to the latest available version:
npm update @coinbase/wallet-sdk

Next steps: